This wiki is locked. Future workgroup activity and specification development must take place at our new wiki. For more information, see this blog post about the new governance model and this post about changes to the website.

OSLC Core Spec V2 Issues

This page has moved to the new wiki for the Core workgroup. Find the latest version there including OPEN and RESOLVED issues and Changes that have happened after FINALIZATION

This document captures the issues raised against the OSLC Core Spec v2.

To see the list of issues that occurred during the convergence phase see OslcCoreV2ConvergenceIssues

Finalization issues

CLOSED and DEFER issues are here. OPEN and RESOLVED issues moved to the new wiki.

This section tracks finalization issues, some of which have been or will be reflected in changes above.

These are the issues raised during the development of the OSLC Core spec up to finalization time.

Note: dates below use US format (mm/dd/yyyy)

Here's what the states mean:

  • OPEN - indicates that we have no response for the issue yet
  • RESOLVED - indicates that we have a response that we believe resolves the issue
  • CLOSED - issue has been resolved and the resolution has been reviewed by the WG
  • DEFERRED - indicates that issue will be addressed in Core Guidance v1.0 during the month after the Core Specification is final.
  • TABLED - indicates that issue will be reconsidered at some later but unspecified date


  1. CLOSED We should reconsider requiring clients to ask for paging
    • No, things work well as is
  2. CLOSED On requests for too large resources, OSLC Services should be able to redirect to URL that specifies paging
  3. CLOSED We need to make it clear that the oslc:ResponseInfo properties' subject resource is the page URL and not the base resource URL
    • This is already clear because paging is always indicated in the URL
  4. CLOSED What does oslc:totalSize mean, is it total number of triples or what?
  5. DEFER oslc:ResponseInfo should be renamed to oslc:Page
    • Consensus: Too late for such a change
  6. DEFER oslc:paging should be renamed to oslc:pagination
    • Consensus: Too late for such a change
  7. DEFER use rdf:next instead of oslc:nextPage
    • Consensus: Too late for such a change
  8. CLOSED In section Graph Patterns. re: "defines a starting subject resource, namely the base URI itself" - First paragraph: Which base URI, specified how? I think you mean the “starting subject resource” but cannot be sure. “Base URI” is particularly troublesome since a given URI can have many potential base URIs. (JA, Dec. 9, 2010)
    • Added clarification, pointing to Service Provider - Creation Factory (Dave Johnson, Dec 9, 2010)
  9. CLOSED Definition of oslc:totalCount is not clear.
    • Resolution is to say something like this: if resource is from a Query Syntax URL, then this is number of RDF nodes, if not then it is a relative measure of the size of the resulting resource across all pages.
    • Resolution: Changes have been applied (DaveJohnson, Dec. 17, 2010)
  10. CLOSED In section "Property tree patterns" - I'd be careful with how this is stated. I think you want to allow implementations to support wider query scopes. If a client understands some RTC-specific property, I think you want to allow it just not require it. Unclear if this is intended to be a MUST NOT, informative, or what. (JA, Dec. 9, 2010)
    • Resolution: we want to allow wider scope but not require it, so now we say "MAY be limited" (DaveJohnson, Dec. 17, 2010)
  11. CLOSED re: "scope of the query is limited to the boundaries of the service". Need definition for "nested properties" Should I read this to imply that the “initial resource”, which may or may not be the same as the “starting subject resource”, must not have any nested properties (whatever those are)? (JA, Dec. 9, 2010)
    • Resolution: added definition for Nested Property (DaveJohnson, Dec. 17, 2010)
  12. CLOSED In section "Prefixed Names" - Don’t recall [Prefixed Names] being defined anywhere in Core. Obvious enough for XML weenies, but probably not for json weenies. What is hear frankly comes across as a circular definition. (JA, Dec. 9, 2010)
    • Resolution: added definition for Prefixed Name and referred to SPARQL spec for precision (DaveJohnson, Dec. 17, 2010)
  13. DEFERRED Query parameters, re: "syntax is formally defined using a common extended form of BNF" (JA, Dec. 9, 2010)
    • Resolution: added reference to wikipedia definition of EBNF. We do need a better grammar and prefer to use ANTLR since it is machine readable and supported by tools, but we will defer until a later version of the Core spec (DaveJohnson, Dec. 17, 2010)
  14. CLOSED Syntax for 'space' - I notice your grammar precludes >1 consecutive space. That seems rather unforgiving. Would be tempted to make it 0:* and then in the text here state that implementations MUST support the single space and MAY support >1, if there is really a good reason to distinguish. (JA, Dec. 9, 2010)
    • Resolution: we are OK with being unforgiving here. The syntax is intended for use in URLs and not written directly by end-users and we'd like to make things easier for those implementing parsers (DaveJohnson, Dec. 17, 2010)
  15. CLOSED Syntax for 'comparison_op' - I don’t think the comparison ops are close to fully specified. I have no idea what it means to compare a Boolean to a string in your language, but I don’t think you prevented that. Let alone boolean1 > boolean2 and similar. String comparisons have all sorts of collating sequence issues that need to be handled if you really want interoperability. (JA, Dec. 9, 2010)
    • Resolution: added note that datatypes and operator semantics MUST work as defined in SPARQL query language (DaveJohnson, Dec. 17, 2010)
  16. CLOSED Syntax for 'in_op' - Nitty I know, but according to the BNF the spaces are not part of the operator. So either you imply that the values being tested cannot contain a comma, or there is some escaping mechanism left unspoken here. (JA, Dec. 9, 2010)
    • Resolution: No change because there is no chance of ambiguity about commas, things without quotes true, false, numbers. Only strings are contained in quotes. (DaveJohnson, Dec. 17, 2010)
  17. CLOSED Syntax for 'literal_value' - re: "datatype URI" - If there is a formal OSLC-defined name for this, encourage you to use it here. As an XML schema weenie, this construction leads me to xs:anyURI at first glance. (JA, Dec. 9, 2010)
    • Resolution: No change because we already refer to the Refer to SPARQL spec for syntax of URIs (DaveJohnson, Dec. 17, 2010)
  18. CLOSED Section 'oslc.searchTerms' re: "Each resource that is returned in the response is annotated with a special property, oslc:score, that gives its match score." Do you mean to say MUST be? (JA, Dec. 9, 2010)
    • Resolution: Yes, this is now a MUST (DaveJohnson, Dec. 17, 2010)
  19. CLOSED Section 'oslc.searchTerms' Integer? Not actually sure why you bother to constrain this at all, but given that you feel the need and given that your example appears to use only integers, worth asking.
    • Resolution: No change. Number is correct because we want to allow floats here (DaveJohnson, Dec. 17, 2010)
  20. CLOSED Section 'oslc.orderBy' - definition needed for Nested Properties (JA, Dec. 9, 2010)
    • Resolution: Fixed by #11 above (DaveJohnson, Dec. 17, 2010)
  21. CLOSED Section '' - "then the matching process does NOT match" - This could easily be read to mean that no members would match (you’d always get 0 members back), which is clearly not the intent. Don’t you just want something like “…then this (absent) criterion does not affect the list of members returned.”? It’s quite hard to clearly define a negative.
    • Resolution: accepted suggested clarification (DaveJohnson, Dec. 17, 2010)
  22. CLOSED oslc:discussion is listed as a common property (in CmSpecificationV2 ) but it is not listed as such in OSLCCoreSpecAppendixA Also suggested is a better name like oslc:discussedBy (WikiName? , 01/07/2011)
    • Response Adding to Appendix A and renaming to oslc:discussedBy. (SteveSpeicher 1/21/2011)
  23. CLOSED oslc:discussion is also listed as a property of oslc:Comment in OSLCCoreSpecAppendixA though with a different meaning (WikiName? , 01/07/2011)
    • Response From oslc:Comment renamed oslc:discussion to oslc:partOfDiscussion. (SteveSpeicher 1/21/2011)
  24. DEFER How to create oslc:Comment resources? Appears to be no guidance, perhaps a Core issue? (WikiName? , 01/07/2011)
    • Response Possible ways to handle: add informative section saying to use creation factories or simply use resource update, adding a new comment entry. There once was a statement about POSTing to the Discussion URL to create comments, not sure why it was removed.. (SteveSpeicher mm/dd/2011)
  25. CLOSED Encoding of UI preview label (SamPadgett, 08/15/2011)
  26. CLOSED JSON formatting rules ambiguities (JohnArwe, 08/15/2011)
  27. CLOSED dialog prefilling awkward statement (JohnArwe, 09/01/2011)
    • Response Clarification on wording suggested in email and made changed in [[][revision (SteveSpeicher 9/21/2011)
  28. CLOSED mail thread resource selection section the first table under that heading contains the string "occurs" in each row of its "Occurs" column instead of zero-or-one etc (JohnArwe, 09/01/2011)
  29. CLOSED mail thread oslc:shortTitle differences (JacobYackenovich, 09/01/2011)
  30. CLOSED How to expose a non-OSLC domain using oslc:domain (JohnArwe 10/21/2011)
  31. CLOSED Icon alt/title text (Bill Andreas 2/15/2012)
  32. CLOSED questions - (IanGreen 3/14/2012)
Topic revision: r194 - 23 Aug 2012 - 22:15:05 - LeeReamsnyder
Main.OslcCoreV2Issues moved from Main.OslcCoreV1Issues on 23 Aug 2011 - 13:36 by SteveSpeicher - put it back
This site is powered by the TWiki collaboration platform Copyright � by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Contributions are governed by our Terms of Use
Ideas, requests, problems regarding this site? Send feedback